CVE-2026-54176: Laravel-Backpack CRUD · Improper Authentication
Affects Laravel-Backpack CRUDSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 7.0.38 or 6.8.14 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.0.38, 6.8.14
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade CRUD and laravel-backpack/CRUD to 7.0.38 or 6.8.14.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Laravel-BackpackCRUD | Affected
| Fixed in
|
| Laravel-BackpackCRUD | Affected
| Fixed in
|
GitHublaravel-backpack/CRUDpkg:github/laravel-backpack/CRUDOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Laravel-Backpack CRUD to version 6.8.14 or later in the 6.x series, or to version 7.0.38 or later in the 7.x series, where this vulnerability is fixed. Until patched, restrict access to authenticated sessions and monitor for unauthorized changes to account recovery information.
Description
backpack/crud provides Create, Read, Update & Delete (CRUD) functions for Backpack, a collection of Laravel packages that help users build custom administration panels. From 6.0.0 until 6.8.14 and 7.0.38, MyAccountController::postAccountInfoForm at POST /admin/edit-account-info permits AccountInfoRequest to update backpack_authentication_column(), which is email by default, without requiring current_password or otherwise verifying the account's existing password. An attacker with a temporary authenticated Backpack session can change the account-recovery email and later use the password-reset flow after the original session expires, converting session compromise into persistent account takeover. The same mechanism permits an insider to set a personal recovery address before access is revoked. The separate password-change endpoint is not affected because it verifies old_password. This issue is fixed in versions 6.8.14 and 7.0.38.
References
- github.com/Laravel-Backpack/CRUD/security/advisories/GHSA-9fw9-8c49-qch8 (opens in a new tab)
- github.com/Laravel-Backpack/CRUD/pull/5990 (opens in a new tab)
- github.com/Laravel-Backpack/CRUD/pull/5994 (opens in a new tab)
- github.com/Laravel-Backpack/CRUD/commit/76c3a6e50e3fbd6d5f633208da5b04acb8322969 (opens in a new tab)
- github.com/Laravel-Backpack/CRUD/commit/8ab94543d880b03c1189acb96b78186323c62a0b (opens in a new tab)
- github.com/Laravel-Backpack/CRUD/releases/tag/6.8.14 (opens in a new tab)
- github.com/Laravel-Backpack/CRUD/releases/tag/7.0.38 (opens in a new tab)