CVE-2026-54322: daytonaio daytona · Insecure Direct Object Reference
Affects daytonaio daytonaSource CVE Database V5
Not known to be exploited · CVSS 7.7 High : upgrade to 0.185.0 soon.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.185.0
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:H/A:LExploitation evidence
Disclosed: evidence found.
CVE published 23 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade daytona and daytonaio/daytona to 0.185.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| daytonaiodaytona | Affected
| Fixed in
|
GitHubdaytonaio/daytonapkg:github/daytonaio/daytonaOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Daytona to version 0.185.0 or later, where this authorization bypass vulnerability is fixed. There is no indication of alternative mitigations or temporary fixes. Patch status is not explicitly confirmed in the advisory, but the fix is stated to be in 0.185.0, so upgrading to this version or newer is recommended.
Description
Daytona is a secure and elastic infrastructure runtime for AI-generated code execution and agent workflows. Prior to 0.185.0, Daytona's organization role update and delete endpoints authorized the caller as an owner of the organization named in the request path, but resolved and mutated the target role by its identifier alone, without verifying the role belonged to that organization. An authenticated user who owns any organization (organizations are self-service) could therefore modify the permissions of, or delete, a role belonging to a different organization, given that role's identifier. This vulnerability is fixed in 0.185.0.