CVE-2026-54510: murtaza-nasir speakr · Improper Authentication
Affects murtaza-nasir speakrSource CVE Database V5
Not known to be exploited · CVSS 7.1 High : upgrade to 0.8.21-alpha soon.
Data as of 1 Nov 2026, 22:58 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.8.21-alpha
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 17 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade speakr and murtaza-nasir/speakr to 0.8.21-alpha.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| murtaza-nasirspeakr | Affected
| Fixed in
|
GitHubmurtaza-nasir/speakrpkg:github/murtaza-nasir/speakrOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in speakr version 0.8.21-alpha. Users should upgrade to this version or later to remediate the issue. No additional mitigation steps are required once the update is applied.
Description
CVE-2026-54510 is an improper authentication vulnerability in murtaza-nasir speakr, a self-hosted transcription web app. Versions prior to 0.8.21-alpha allow an attacker to bypass CSRF protection by sending a crafted token in a query parameter, which disables CSRF checks for the targeted view during the worker lifetime. This can lead to unauthorized modifications of user profile data, settings, and administrative status. Additionally, the change_password route can be abused to set a local password on SSO-only accounts without verifying the current password. The issue is fixed in version 0.8.21-alpha.