Skip to main content
VulnerabilityPublished

CVE-2026-54544: ShaneIsrael fireshare · Server-Side Request Forgery (SSRF)

Affects ShaneIsrael fireshareSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.2 High : upgrade to 1.6.16 soon.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.6.16
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade fireshare and shaneisrael/fireshare to 1.6.16.

Affected software

ProductAffectedFixed in
ShaneIsraelfireshareAffected
  • <1.6.16
Fixed in
  • 1.6.16
GitHubshaneisrael/firesharepkg:github/shaneisrael/fireshareOther threatsAffected
  • <1.6.16
Fixed in
  • 1.6.16

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Fireshare to version 1.6.16 or later, where the missing authentication checks on the vulnerable API endpoints have been added. No other mitigation is required as the patch addresses the issue directly.

Description

Fireshare versions prior to 1.6.16 contain a Server-Side Request Forgery (SSRF) vulnerability due to missing authentication on two API endpoints. An unauthenticated attacker can make the server send arbitrary HTTP POST requests to any URL, including internal network resources and cloud metadata services. This vulnerability is patched in version 1.6.16.

References

Community reviews

Loading reviews…