Skip to main content
VulnerabilityPublished

CVE-2026-54559: cmusphinx pocketsphinx · Memory Buffer Overflow

Affects cmusphinx pocketsphinxSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 5.1.1 when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.1.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade pocketsphinx and cmusphinx/pocketsphinx to 5.1.1.

Affected software

ProductAffectedFixed in
cmusphinxpocketsphinxAffected
  • <5.1.1
Fixed in
  • 5.1.1
GitHubcmusphinx/pocketsphinxpkg:github/cmusphinx/pocketsphinxOther threatsAffected
  • <5.1.1
Fixed in
  • 5.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade PocketSphinx to version 5.1.1 or later, where this vulnerability is fixed. Users of 5prealpha versions without backported patches must migrate to the fixed release. Restrict write permissions to directories specified by POCKETSPHINX_PATH to prevent unauthorized model file modifications.

Description

CVE-2026-54559 affects PocketSphinx, a small speech recognizer, due to improper boundary validation in language-model loaders and unbounded string usage in acoustic-model loaders. This can lead to stack or heap buffer overflows and memory corruption when loading invalid or malicious model files. The vulnerability is fixed in version 5.1.1. Users of versions prior to 5.1.1 should upgrade to mitigate this issue.

References

Community reviews

Loading reviews…