CVE-2026-54576: MidnightBSD mport · Link Following
Affects MidnightBSD mportSource CVE Database V5
Not known to be exploited · CVSS 5.8 Medium : upgrade to 2.7.8 when convenient.
Data as of 1 Nov 2026, 22:58 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.7.8
CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 17 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade mport and midnightbsd/mport to 2.7.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| MidnightBSDmport | Affected
| Fixed in
|
GitHubmidnightbsd/mportpkg:github/midnightbsd/mportOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade mport to version 2.7.8 or later, where this vulnerability is fixed. No other mitigation is required as the fix addresses the improper link resolution issue directly.
Description
CVE-2026-54576 is a vulnerability in the MidnightBSD package manager 'mport' prior to version 2.7.8. The issue involves improper link resolution before file access during package installation, allowing a local attacker with write access to a target directory to replace a file with a symbolic link. This can cause privileged ownership or mode changes to be applied to an attacker-controlled path, potentially compromising filesystem integrity or permissions. The vulnerability is fixed in version 2.7.8.
References
- github.com/MidnightBSD/mport/security/advisories/GHSA-23g3-7fv3-3ccf (opens in a new tab)
- github.com/MidnightBSD/mport/pull/150 (opens in a new tab)
- github.com/MidnightBSD/mport/commit/4676ac05b1056b54a3d38d03ae8a478bf12c9abe (opens in a new tab)
- github.com/MidnightBSD/mport/releases/tag/2.7.8 (opens in a new tab)