Skip to main content
VulnerabilityPublished

CVE-2026-54597: itflow · SQL Injection

Affects itflowSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.3 High : upgrade to 26.07 soon.

Data as of 1 Nov 2026, 22:58 UTC

CVSS 3.1 base score
8.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 26.07
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade itflow and itflow-org/itflow to 26.07.

Affected software

ProductAffectedFixed in
itflow-orgitflowAffected
  • <26.07
Fixed in
  • 26.07
GitHubitflow-org/itflowpkg:github/itflow-org/itflowOther threatsAffected
  • <26.07
Fixed in
  • 26.07

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to itflow version 26.07 or later, where this vulnerability is fixed. No other mitigations are specified. Patch status is confirmed as fixed in version 26.07.

Description

A SQL injection vulnerability (CWE-89) exists in itflow versions prior to 26.07. Authenticated users with module_support write permission and access to credential records can exploit a time-based blind SQL injection via the expires parameter in the share_generate_link handler. This flaw allows execution of conditional database queries that can expose sensitive data including password hashes, SMTP credentials, API keys, encrypted vault data, and database metadata. The vulnerability is fixed in version 26.07.

References

Community reviews

Loading reviews…