Skip to main content
VulnerabilityPublished Updated

CVE-2026-54603: ruby-oauth oauth2 · Information Exposure

Affects ruby-oauth oauth2Source CVE Database V5

0

Not known to be exploited · CVSS 8.6 High : upgrade to 2.0.22 soon.

Data as of 28 Oct 2026, 05:11 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.0.22
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade ruby-oauth oauth2 to 2.0.22.

Affected software

ProductAffectedFixed in
ruby-oauthoauth2Affected
  • >=0.4.0 <2.0.22
Fixed in
  • 2.0.22

AI-suggested

Upgrade the ruby-oauth oauth2 library to version 2.0.22 or later, where this vulnerability is fixed. No other mitigation or temporary fix is indicated. Patch status is confirmed by the version fix information.

Description

OAuth2 is a Ruby wrapper for the OAuth 2.0 and 2.1 authorization frameworks, including OpenID Connect (OIDC). From 0.4.0 to 2.0.21, a protocol-relative redirect Location returned to OAuth2::Client#request overrides the request authority, so the bearer Authorization header is sent to an attacker-controlled host, leaking the credential. This issue is fixed in version 2.0.22.

References

Community reviews

Loading reviews…