Skip to main content
VulnerabilityPublished

CVE-2026-54655: koxudaxi datamodel-code-generator · Code Injection

Affects koxudaxi datamodel-code-generatorSource CVE Database V5

0

Not known to be exploited · CVSS 7.8 High : upgrade to 0.60.2 soon.

Data as of 27 Oct 2026, 17:11 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.60.2
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade koxudaxi datamodel-code-generator to 0.60.2.

Affected software

ProductAffectedFixed in
koxudaxidatamodel-code-generatorAffected
  • >=0.51.0 <0.60.2
Fixed in
  • 0.60.2

AI-suggested

Upgrade datamodel-code-generator to version 0.60.2 or later, where this vulnerability is fixed. No other official remediation or temporary fixes are documented. Until upgrading, avoid importing generated modules from untrusted or attacker-controlled JSON Schema inputs.

Description

A code injection vulnerability exists in koxudaxi datamodel-code-generator versions 0.51.0 through before 0.60.2. The issue arises because attacker-controlled JSON Schema content can inject Python code into generated field annotations without sufficient validation, leading to code execution when the generated module is imported. This vulnerability is fixed in version 0.60.2.

References

Community reviews

Loading reviews…