Skip to main content
VulnerabilityPublished

CVE-2026-54660: acacode swagger-typescript-api · Information Exposure

Affects acacode swagger-typescript-apiSource CVE Database V5

0

Not known to be exploited · CVSS 7.4 High : upgrade to 13.12.2 soon.

Data as of 27 Oct 2026, 17:11 UTC

CVSS 3.1 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 13.12.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade acacode swagger-typescript-api to 13.12.2.

Affected software

ProductAffectedFixed in
acacodeswagger-typescript-apiAffected
  • <13.12.2
Fixed in
  • 13.12.2
npmswagger-typescript-apipkg:npm/swagger-typescript-apiOther threatsAffected
  • <13.12.2
Fixed in
  • 13.12.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade swagger-typescript-api to version 13.12.2 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated.

Description

A vulnerability in swagger-typescript-api prior to version 13.12.2 allows exposure of sensitive bearer tokens. The issue occurs because the authorization token is forwarded to every URL fetched when resolving external references in OpenAPI specifications. This can lead to an attacker-controlled OpenAPI spec exfiltrating the developer or CI bearer token to a cross-origin endpoint. The vulnerability is fixed in version 13.12.2.

References

Community reviews

Loading reviews…