Skip to main content
VulnerabilityPublished

CVE-2026-54679: jqlang jq · Integer Overflow or Wraparound

Affects jqlang jqSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 1.8.2 when convenient.

Data as of 6 Nov 2026, 23:24 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.8.2
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade jq and jqlang/jq to 1.8.2.

Affected software

ProductAffectedFixed in
jqlangjqAffected
  • <1.8.2
Fixed in
  • 1.8.2
GitHubjqlang/jqpkg:github/jqlang/jqOther threatsAffected
  • <1.8.2
Fixed in
  • 1.8.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade jq to version 1.8.2 or later, where this integer overflow and buffer overrun vulnerability has been fixed. No other mitigation or temporary workaround is indicated.

Description

jq is a command-line JSON processor. Prior to 1.8.2, on 32bit system, jvp_string_append has a chance of integer/multiple overflowing and then causing a massive buffer overrun. This vulnerability is fixed in 1.8.2.

References

Community reviews

Loading reviews…