Skip to main content
VulnerabilityPublished

CVE-2026-54680: kube-logging logging-operator · Injection

Affects kube-logging logging-operatorSource CVE Database V5

0

Not known to be exploited · CVSS 9.9 Critical : upgrade to 6.6.0 as a priority.

Data as of 28 Oct 2026, 05:11 UTC

CVSS 3.1 base score
9.9Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.6.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade logging-operator and kube-logging/logging-operator to 6.6.0.

Affected software

ProductAffectedFixed in
kube-logginglogging-operatorAffected
  • <6.6.0
Fixed in
  • 6.6.0
GitHubkube-logging/logging-operatorpkg:github/kube-logging/logging-operatorOther threatsAffected
  • <6.6.0
Fixed in
  • 6.6.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade kube-logging logging-operator to version 6.6.0 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is documented. Patch status is confirmed fixed in 6.6.0.

Description

A critical injection vulnerability (CVE-2026-54680) exists in kube-logging logging-operator versions prior to 6.6.0. The Fluentd configuration renderer writes certain CRD strings directly into configuration files without proper escaping, allowing an attacker with permission to create Flow resources to inject malicious Fluentd <match **> blocks. This can lead to arbitrary command execution within the Fluentd aggregator. The issue is resolved in version 6.6.0.

References

Community reviews

Loading reviews…