CVE-2026-54851: Contact Form by WPForms (WordPress plugin) · Cross-site Scripting
Affects Contact Form by WPForms (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 7.1 High : upgrade to 2.0.3.1 soon.
Data as of 4 Nov 2026, 07:28 UTC
Thin evidence
One scorer or none| CNA (Patchstack) | CVSS 3.1 | 7.1 |
|---|
- Patch
- Available – fixed in 2.0.3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 4 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade Contact Form by WPForms (WordPress plugin) to 2.0.3.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Contact Form by WPFormswpforms-lite | Affected
| Fixed in
|
AI-suggested
A fixed version 2.0.3.1 is available and should be applied to remediate this vulnerability. Users of Contact Form by WPForms should upgrade to version 2.0.3.1 or later to eliminate the risk. No additional mitigation steps are indicated by the vendor advisory.
Description
CVE-2026-54851 is a reflected cross-site scripting (XSS) vulnerability in the Contact Form by WPForms plugin by Awesomemotive. It affects versions from initial releases up to 2.0.3. The vulnerability allows improper neutralization of input during web page generation, potentially enabling an attacker to execute arbitrary scripts in the context of the victim's browser. A fix is available in version 2.0.3.1.