CVE-2026-55239: msgbyte tianji · SQL Injection
Affects msgbyte tianjiSource CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 1.31.29 soon.
Data as of 26 Oct 2026, 13:07 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.31.29
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 15 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade tianji and msgbyte/tianji to 1.31.29.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| msgbytetianji | Affected
| Fixed in
|
GitHubmsgbyte/tianjipkg:github/msgbyte/tianjiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Tianji to version 1.31.29 or later, where the vulnerability is fixed by properly parameterizing the timezone value in SQL queries. No other mitigations are indicated by the vendor advisory.
Description
Tianji, an open source analytics and monitoring platform, contains an SQL injection vulnerability in the getDateQuery() function prior to version 1.31.29. The vulnerability arises because the timezone value is interpolated directly into raw SQL without parameter binding, allowing authenticated workspace members, including read-only viewers, to execute arbitrary SQL commands. This can lead to unauthorized disclosure or modification of sensitive data such as credentials, API keys, and tenant information, or cause service disruption. The issue is resolved in version 1.31.29.