CVE-2026-55600: Part-DB-server · Cross-site Scripting
Affects Part-DB-serverSource CVE Database V5
Not known to be exploited · CVSS 5.7 Medium : upgrade to 2.12.2 when convenient.
Data as of 26 Oct 2026, 16:39 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.12.2
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:N/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 23 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Part-DB-server and part-db/Part-DB-server to 2.12.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Part-DBPart-DB-server | Affected
| Fixed in
|
GitHubpart-db/Part-DB-serverpkg:github/part-db/Part-DB-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Part-DB-server to version 2.12.2 or later, where this vulnerability is patched. No additional mitigation is required as the fix properly neutralizes user input in Part names before rendering.
Description
Part-DB-server versions prior to 2.12.2 contain a stored cross-site scripting (XSS) vulnerability. This occurs because user-controlled Part names are rendered using Twig's |raw filter without proper neutralization, allowing injection of arbitrary HTML elements into the BOM validation result page. Although JavaScript execution is blocked by the Content Security Policy, attackers can still inject HTML links, forms, images, and CSS UI elements. The vulnerability is fixed in version 2.12.2.