Skip to main content
VulnerabilityPublished Updated

CVE-2026-55872: mayerbalintdev GYM-One · Cross-site Scripting

Affects mayerbalintdev GYM-OneSource CVE Database V5

0

Not known to be exploited · CVSS 8.7 High : upgrade to 1.4.1 soon.

Data as of 26 Oct 2026, 14:18 UTC

CVSS 3.1 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.4.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade GYM-One and mayerbalintdev/GYM-One to 1.4.1.

Affected software

ProductAffectedFixed in
mayerbalintdevGYM-OneAffected
  • <1.4.1
Fixed in
  • 1.4.1
GitHubmayerbalintdev/GYM-Onepkg:github/mayerbalintdev/GYM-OneOther threatsAffected
  • <1.4.1
Fixed in
  • 1.4.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade GYM One to version 1.4.1 or later, where this vulnerability is fixed by properly encoding output in the affected admin/users/index.php page. No other mitigation is required once the software is updated.

Description

A persistent cross-site scripting (XSS) vulnerability exists in GYM One gym management software versions prior to 1.4.1. The vulnerability occurs because the admin/users/index.php page renders user profile fields (firstname, lastname, email) without proper HTML encoding. An attacker able to store malicious script code in these fields can execute arbitrary scripts in an administrator's browser when they view the user list, potentially compromising administrator session data and privileges. This issue is fixed in version 1.4.1.

References

Community reviews

Loading reviews…