CVE-2026-55969: Apache Thrift · Integer Overflow or Wraparound
Affects Apache ThriftSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 0.24.0 soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 1.0% chance of exploitation in 30 days – higher than 63% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.24.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Apache Thrift and github.com/apache/thrift and ApacheThrift to 0.24.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Thrift | Affected
| Fixed in
|
Gogithub.com/apache/thriftpkg:golang/github.com/apache/thriftOther threats | Affected
| Fixed in
|
NuGetApacheThriftpkg:nuget/ApacheThriftOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Thrift to version 0.24.0 or later, where this vulnerability has been fixed. No other mitigation or temporary workaround is indicated. Patch status is confirmed by the vendor advisory recommending upgrade to 0.24.0.
Description
Integer Overflow or Wraparound vulnerability in Apache Thrift C++, c_glib, Go, netstd, Delphi and Haxe bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.