Skip to main content
VulnerabilityPublished

CVE-2026-55970: Apache Thrift · Buffer Over-read

Affects Apache ThriftSource CVE Database V5

0

Not known to be exploited · CVSS 6.9 Medium : upgrade to 0.24.0 when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.24.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Apache Thrift to 0.24.0.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache ThriftAffected
  • <0.24.0
Fixed in
  • 0.24.0

AI-suggested

Users should upgrade Apache Thrift to version 0.24.0 or later, which contains the official fix for this vulnerability. No other mitigation or temporary workaround is indicated.

Description

Buffer Over-read vulnerability in Apache Thrift C++ bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

References

Community reviews

Loading reviews…