Skip to main content
VulnerabilityPublished Updated

CVE-2026-56104: chainlit · Missing Authorization

Affects chainlitSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 2.10.1 soon.

Data as of 8 Nov 2026, 14:34 UTC

CVSS 4.0 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.8
CNA (VulnCheck)CVSS 3.18.2
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Total control over the software or total information disclosure

CISA SSVC assessment, 2026-06-22.

Patch
Available – fixed in 2.10.1
CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 8 Nov 2026.

What to do

Upgrade chainlit to 2.10.1.

Affected software

ProductAffectedFixed in
ChainlitchainlitAffected
  • <2.10.1
Fixed in–
PyPIchainlitpkg:pypi/chainlitOther threatsAffected
  • <2.10.1
Fixed in
  • 2.10.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Chainlit before 2.10.1 contains a session hijacking vulnerability that allows unauthenticated attackers to restore and inherit authenticated user sessions by presenting a valid sessionId during WebSocket session restoration without ownership verification. Attackers can exploit the restore_existing_session path to assume a victim's permissions and roles, enabling unauthorized invocation of tools and access to data restricted to the authenticated victim.

References

Community reviews

Loading reviews…