Skip to main content
VulnerabilityPublished Updated

CVE-2026-56317: Nuxt · Cross-site Scripting

Affects NuxtSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 2.3 Low : upgrade to 4.4.7 when convenient.

Data as of 8 Nov 2026, 14:48 UTC

CVSS 4.0 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.02.3
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Limited control over the software or limited information exposure

CISA SSVC assessment, 2026-06-24.

Patch
Available – fixed in 4.4.7, 3.21.7
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 8 Nov 2026.

What to do

Upgrade Nuxt to 4.4.7; Nuxt to 3.21.7; Nuxt to 4.4.7 or 3.21.7.

Affected software

ProductAffectedFixed in
NuxtNuxtAffected
  • >=4.0.0 <4.4.7
Fixed in
  • 4.4.7
NuxtNuxtAffected
  • <3.21.7
Fixed in
  • 3.21.7
npmNuxtpkg:npm/NuxtOther threatsAffected
  • >=4.0.0 <4.4.7
  • <3.21.7
Fixed in
  • 4.4.7
  • 3.21.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Nuxt to version 4.4.7 or later, or 3.21.7 or later, where this vulnerability is fixed. No other mitigation is indicated by the vendor advisory.

Description

CVE-2026-56317 is a cross-site scripting (XSS) vulnerability in Nuxt versions before 4.4.7 and 3.x versions before 3.21.7. The issue exists in the NoScript component, which writes slot content to innerHTML without proper escaping. This allows attackers to inject malicious scripts via untrusted data, such as route.query parameters, which execute in the document context when the noscript tag is implicitly closed by script tags.

References

Community reviews

Loading reviews…