Skip to main content
VulnerabilityPublished Updated

CVE-2026-56340: vLLM · Improper Input Validation

Affects vLLMSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 8.7 High : upgrade to 0.13.0 soon.

Data as of 8 Nov 2026, 14:47 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Sources agree

CVSS scores by source
CNA (VulnCheck)CVSS 4.08.7
CNA (VulnCheck)CVSS 3.18.8
ADP (redhat-SADP)CVSS 3.18.8
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Total control over the software or total information disclosure

CISA SSVC assessment, 2026-06-24.

Patch
Available – fixed in 0.13.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 8 Nov 2026.

What to do

Upgrade vLLM to 0.13.0.

Affected software

ProductAffectedFixed in
vLLMvLLMAffected
  • >=0.10.2 <0.13.0
Fixed in
  • 0.13.0
PyPIvLLMpkg:pypi/vLLMOther threatsAffected
  • >=0.10.2 <0.13.0
Fixed in
  • 0.13.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in vLLM version 0.13.0. Users should upgrade to this fixed version when possible. Until then, disable the prompt-embeds feature if it is not required. Restrict access to multimodal embedding requests by applying authentication and rate limiting on inference APIs to reduce exposure. These mitigations are recommended by the vendor advisory.

Description

CVE-2026-56340 is a vulnerability in vLLM versions 0.10.2 through before 0.13.0 involving improper input validation of sparse tensors in multimodal embeddings processing. Attackers can submit malformed embedding requests with invalid tensor indices when the prompt-embeds feature is enabled, causing crashes, resource exhaustion (denial of service), and potential out-of-bounds memory corruption that may lead to arbitrary code execution. This issue continues from a prior vulnerability (CVE-2025-62164) whose fix only disabled the feature by default rather than addressing the root cause. The vulnerability is fixed in vLLM 0.13.0.

References

Community reviews

Loading reviews…