CVE-2026-56363: ImageMagick · Integer Overflow or Wraparound
Affects ImageMagickSource GCVE Database
Not known to be exploited · CVSS 4.8 Medium.
Data as of 26 Oct 2026, 06:22 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ImageMagick ImageMagick | Affected
| Fixed in– |
AI-suggested
Users should upgrade to ImageMagick version 7.1.2-22 or later once it is released to address this vulnerability. Until then, avoid processing untrusted input that could trigger the flaw.
Description
ImageMagick versions before 7.1.2-22 have a vulnerability in binomial kernel processing where supplying a large binomial kernel value can cause an integer overflow leading to a division by zero and application crash. This results in a denial of service condition.