CVE-2026-56367: ImageMagick · Out-of-bounds Read
Affects ImageMagickSource CVE Database V5
Not known to be exploited · CVSS 6.3 Medium : upgrade to 7.1.2-15 when convenient.
Data as of 8 Nov 2026, 14:47 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 6.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 3.7 |
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Limited control over the software or limited information exposure
CISA SSVC assessment, 2026-06-22.
- Patch
- Available – fixed in 7.1.2-15, 6.9.13-40
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 21 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 8 Nov 2026.
What to do
Upgrade ImageMagick to 7.1.2-15; ImageMagick to 6.9.13-40; imagemagick/ImageMagick to 7.1.2-15 or 6.9.13-40.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ImageMagickImageMagick | Affected
| Fixed in
|
| ImageMagickImageMagick | Affected
| Fixed in
|
GitHubimagemagick/ImageMagickpkg:github/imagemagick/ImageMagickOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade ImageMagick to version 7.1.2-15 or later, or 6.9.13-40 or later, where this vulnerability is fixed. No additional mitigation steps are indicated by the vendor advisory. Applying the official patch fully addresses the issue.
Description
CVE-2026-56367 is an integer overflow vulnerability in ImageMagick's PSB (PSD v2) RLE decoding path affecting versions before 7.1.2-15 and 6.9.13-40. This flaw causes a heap out-of-bounds read on 32-bit builds when processing crafted PSB files, potentially leading to information disclosure or application crashes.