Skip to main content
VulnerabilityPublished Updated

CVE-2026-56780: modoboa · Insecure Direct Object Reference

Affects modoboaSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.7 High : upgrade to 2.9.0 soon.

Data as of 8 Nov 2026, 14:47 UTC

CVSS 4.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.07.7
CNA (VulnCheck)CVSS 3.17.5
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Total control over the software or total information disclosure

CISA SSVC assessment, 2026-07-01.

Patch
Available – fixed in 2.9.0
CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 8 Nov 2026.

What to do

Upgrade modoboa to 2.9.0.

Affected software

ProductAffectedFixed in
modoboamodoboaAffected
  • <2.9.0
Fixed in
  • 2.9.0
PyPImodoboapkg:pypi/modoboaOther threatsAffected
  • <2.9.0
Fixed in
  • 2.9.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade modoboa to version 2.9.0 or later, where this vulnerability is fixed. No other mitigations are indicated by the vendor advisory.

Description

CVE-2026-56780 is an authorization bypass vulnerability in modoboa versions before 2.9.0. It affects the PUT /api/v1/accounts/{pk}/password/ endpoint, allowing domain administrators to change any user's password, including superadmin accounts. This flaw enables attackers with domain admin privileges to bypass object-level access controls and achieve full account takeover by resetting superadmin passwords.

References

Community reviews

Loading reviews…