Skip to main content
VulnerabilityPublished

CVE-2026-56828: shopperlabs shopper · Improper Authorization

Affects shopperlabs shopperSource CVE Database V5

0

Not known to be exploited · CVSS 8.8 High : upgrade to 2.8.1 soon.

Data as of 28 Oct 2026, 15:57 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.8.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade shopper and shopperlabs/shopper to 2.8.1.

Affected software

ProductAffectedFixed in
shopperlabsshopperAffected
  • >=2.8.0 <2.8.1
Fixed in
  • 2.8.1
GitHubshopperlabs/shopperpkg:github/shopperlabs/shopperOther threatsAffected
  • >=2.8.0 <2.8.1
Fixed in
  • 2.8.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to shopper version 2.8.1 or later, where these authorization issues are fixed. No additional mitigation is required once the update is applied. Until then, restrict access to users with only necessary permissions and monitor for unauthorized administrative actions.

Description

CVE-2026-56828 is an improper authorization vulnerability in shopperlabs shopper versions 2.8.0 up to but not including 2.8.1. It affects several Livewire admin components where users with limited permissions (view_users and access_dashboard) can escalate privileges by mutating permissions, creating administrators, or deleting roles. This flaw allows unauthorized permission changes, creation of pre-verified administrators, and deletion of roles, potentially causing privilege escalation and denial of service via role-based access control (RBAC) disruption. The issue is fixed in version 2.8.1.

References

Community reviews

Loading reviews…