Skip to main content
VulnerabilityPublished

CVE-2026-56840: MervinPraison PraisonAI · Cross-site Scripting

Affects MervinPraison PraisonAISource CVE Database V5

0

Not known to be exploited · CVSS 8.8 High : upgrade to 4.6.59 soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.6.59
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade PraisonAI and mervinpraison/PraisonAI to 4.6.59.

Affected software

ProductAffectedFixed in
MervinPraisonPraisonAIAffected
  • >=4.5.2 <4.6.59
Fixed in
  • 4.6.59
GitHubmervinpraison/PraisonAIpkg:github/mervinpraison/PraisonAIOther threatsAffected
  • >=4.5.2 <4.6.59
Fixed in
  • 4.6.59

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade PraisonAI to version 4.6.59 or later, where this vulnerability has been patched. No other mitigations are indicated by the vendor advisory. Users should ensure they do not use affected versions in production environments.

Description

CVE-2026-56840 is a high-severity cross-site scripting (XSS) vulnerability in MervinPraison's PraisonAI multi-agent teams system. Versions from 4.5.2 up to but not including 4.6.59 are affected. The vulnerability occurs because the HTTPApproval component renders attacker-controlled input directly into the approval dashboard HTML without proper neutralization. This allows an attacker to inject JavaScript that executes in the context of the dashboard, potentially approving malicious tool requests automatically. The issue has been patched in version 4.6.59.

References

Community reviews

Loading reviews…