CVE-2026-56968: GNU SASL · Numeric Range Comparison Without Minimum Check
Affects GNU SASLSource CVE Database V5
Not known to be exploited · CVSS 3.7 Low : upgrade to 2.2.4 when convenient.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.2.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 23 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade GNU SASL to 2.2.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| GNUGNU SASL | Affected
| Fixed in
|
Description
GNU SASL before 2.2.4 lacks sanitization of a short challenge in _gsasl_ntlm_client_step in the NTLM client, which could result in memory disclosure via a crafted server.
References
- lists.gnu.org/archive/html/help-gsasl/2026-06/msg00000.html (opens in a new tab)
- lists.debian.org/debian-security-announce/2026/msg00259.html (opens in a new tab)
- ftp.gnu.org/gnu/gsasl/ (opens in a new tab)
- gnu.org/software/gsasl/ (opens in a new tab)
- lists.debian.org/debian-lts-announce/2026/07/msg00049.html (opens in a new tab)