Skip to main content
VulnerabilityPublished

CVE-2026-57149: plone.app.portlets · Eval Injection

Affects plone.app.portletsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.9 Critical · fixed in 7.0.2 : patch plone.app.portlets as a priority.

Data as of 6 Nov 2026, 23:24 UTC

CVSS 3.1 base score
9.9Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.2, 6.0.4, 5.0.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade plone.app.portlets and plone-app-portlets to 7.0.2, 6.0.4 or 5.0.8.

Affected software

ProductAffectedFixed in
ploneplone.app.portletsAffected
  • >=7.0.0 <7.0.2
Fixed in
  • 7.0.2
ploneplone.app.portletsAffected
  • >=6.0.0 <6.0.4
Fixed in
  • 6.0.4
ploneplone.app.portletsAffected
  • >=5.0.0 <5.0.8
Fixed in
  • 5.0.8
PyPIplone-app-portletspkg:pypi/plone-app-portletsOther threatsAffected
  • >=5.0.0 <5.0.8
  • >=6.0.0 <6.0.4
  • >=7.0.0 <7.0.2
Fixed in
  • 5.0.8
  • 6.0.4
  • 7.0.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in plone.app.portlets versions 5.0.8, 6.0.4, and 7.0.2. Users should upgrade to these or later versions to remediate the vulnerability. Until patched, mitigate by restricting the ManageOwnPortlets permission from untrusted roles and limiting Manage portlets permission to trusted administrators. Additionally, unregister the Classic portlet if it is not needed by editing portlets.xml or disable it by customizing its template to prevent it from being shown. These mitigations reduce the risk of exploitation by limiting who can configure vulnerable portlets.

Description

CVE-2026-57149 is a critical vulnerability in plone.app.portlets affecting versions 5.0.0 up to but not including 5.0.8, 6.0.0 up to but not including 6.0.4, and 7.0.0 up to but not including 7.0.2. The Classic portlet improperly evaluates user-supplied template/macro fields as full TALES expressions, allowing authenticated users with permission to configure Classic portlets to execute arbitrary code in the Plone server process. This leads to privilege escalation from an authenticated user to server-side code execution. The issue has been patched in versions 5.0.8, 6.0.4, and 7.0.2. Workarounds include restricting portlet management permissions and disabling the Classic portlet.

References

Community reviews

Loading reviews…