CVE-2026-57188: asterisk · Out-of-bounds Write
Affects asteriskSource CVE Database V5
Not known to be exploited · CVSS 7.1 High · fixed in 23.4.1 : patch asterisk soon.
Data as of 27 Oct 2026, 18:27 UTC
- Patch
- Available – fixed in 23.4.1, 22.10.1, 21.12.3 +3
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade asterisk to 23.4.1, 22.10.1, 21.12.3 or 20.20.1; certified-asterisk to 22.8-cert3 or 20.7-cert11.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| asteriskasterisk | Affected
| Fixed in
|
| asteriskasterisk | Affected
| Fixed in
|
| asteriskasterisk | Affected
| Fixed in
|
| asteriskasterisk | Affected
| Fixed in
|
| asteriskcertified-asterisk | Affected
| Fixed in
|
| asteriskcertified-asterisk | Affected
| Fixed in
|
AI-suggested
Apply the official patches by upgrading to Asterisk versions 20.20.1, 21.12.3, 22.10.1, 23.4.1 or Certified Asterisk 20.7-cert11, 22.8-cert3 or later. These versions contain fixes for this vulnerability. No other mitigations are specified. Ensure the res_xmpp module is only loaded and configured if necessary, and restrict XMPP account access to trusted users.
Description
CVE-2026-57188 is a high-severity stack buffer overflow vulnerability in the res_xmpp module of Asterisk, an open source telephony toolkit. It affects versions prior to 20.20.1, 21.12.3, 22.10.1, 23.4.1 and certain Certified Asterisk releases. An authenticated attacker with an XMPP account on the same or federated server can exploit this by sending crafted packets to cause out-of-bounds writes. The vulnerability requires the res_xmpp module to be loaded and an XMPP connection configured. Fixed versions are available.
References
- github.com/asterisk/asterisk/security/advisories/GHSA-mxgm-8c6f-5p8f (opens in a new tab)
- github.com/asterisk/asterisk/commit/12072a559f592736a44dd9fbe1594e84714edfb4 (opens in a new tab)
- github.com/asterisk/asterisk/commit/1328dbb503da4aa11a480a9c28e170f17e5f4e84 (opens in a new tab)
- github.com/asterisk/asterisk/commit/3c4b08cf94eeaa3faefb3ae6c2d6ce1bd9747a13 (opens in a new tab)
- github.com/asterisk/asterisk/commit/433102c16b8edfc31d28c96166fef03fe72fb923 (opens in a new tab)
- github.com/asterisk/asterisk/commit/5e626250628b2579530f3f17e7b0aa37d082873b (opens in a new tab)
- github.com/asterisk/asterisk/commit/d570a85e45153a36919ace5d0ab06a195b30f9d1 (opens in a new tab)
- github.com/asterisk/asterisk/commit/e329a6803ac5214028f98cc5f0b7167d66e32c08 (opens in a new tab)
- github.com/asterisk/asterisk/releases/tag/20.20.1 (opens in a new tab)
- github.com/asterisk/asterisk/releases/tag/21.12.3 (opens in a new tab)
- github.com/asterisk/asterisk/releases/tag/22.10.1 (opens in a new tab)
- github.com/asterisk/asterisk/releases/tag/23.4.1 (opens in a new tab)
- github.com/asterisk/asterisk/releases/tag/certified-20.7-cert11 (opens in a new tab)
- github.com/asterisk/asterisk/releases/tag/certified-22.8-cert3 (opens in a new tab)
- github.com/asterisk/asterisk/tree/24.0.0-pre1 (opens in a new tab)