Skip to main content
VulnerabilityPublished

CVE-2026-57448: mrblomblo blombooru · Server-Side Request Forgery (SSRF)

Affects mrblomblo blombooruSource CVE Database V5

0

Not known to be exploited · CVSS 6.2 Medium : upgrade to 1.40.0 when convenient.

Data as of 28 Oct 2026, 21:58 UTC

CVSS 4.0 base score
6.2Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.40.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:H/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade blombooru and mrblomblo/blombooru to 1.40.0.

Affected software

ProductAffectedFixed in
mrblombloblombooruAffected
  • <1.40.0
Fixed in
  • 1.40.0
GitHubmrblomblo/blomboorupkg:github/mrblomblo/blombooruOther threatsAffected
  • <1.40.0
Fixed in
  • 1.40.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade blombooru to version 1.40.0 or later, where this SSRF vulnerability is fixed. No additional mitigation is required if the application is updated. Since administrator authentication is required, ensure that administrator credentials are well protected.

Description

CVE-2026-57448 is a server-side request forgery (SSRF) vulnerability in the mrblomblo blombooru application prior to version 1.40.0. The vulnerability exists in the administrator-only GET /proxy-image endpoint, which fetches URLs server-side without proper validation. This allows an authenticated administrator to access internal network services and cloud instance metadata, potentially exposing sensitive credentials. The issue is fixed in version 1.40.0.

References

Community reviews

Loading reviews…