Skip to main content
VulnerabilityPublished Updated

CVE-2026-5747: AWS Firecracker · Out-of-bounds Write

Affects AWS FirecrackerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High · patch available : patch AWS Firecracker soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available
CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
AWSFirecrackerAffected
  • >=1.13.0 <=1.14.3
  • =1.15.0
Fixed in–
GitHubfirecracker-microvm/firecrackerpkg:github/firecracker-microvm/firecrackerOther threatsAffected
  • =1.13.0
  • =1.15.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

AWS has released official fixes in Firecracker versions 1.14.4 and 1.15.1 and later. Users should upgrade to these versions to remediate the vulnerability. Since Firecracker is a cloud service, AWS manages remediation for the hosted service, but users running self-managed Firecracker instances must apply the updates. No other specific mitigations are indicated by the vendor advisory.

Description

CVE-2026-5747 is an out-of-bounds write vulnerability in the virtio PCI transport component of AWS Firecracker versions 1.13.0 through 1.14.3 and 1.15.0 on x86_64 and aarch64 architectures. A local guest user with root privileges could exploit this flaw to crash the Firecracker VMM process or potentially execute arbitrary code on the host. Exploitation to achieve code execution requires additional conditions such as a custom guest kernel or specific snapshot configurations. AWS has released fixed versions 1.14.4 and 1.15.1 and later to address this issue.

References

Community reviews

Loading reviews…