Skip to main content
VulnerabilityPublished Updated

CVE-2026-57576: plone.app.dexterity · Uncontrolled Resource Consumption

Affects plone.app.dexteritySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 4.1.3 or 3.2.3 when convenient.

Data as of 5 Nov 2026, 23:24 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.1.3, 3.2.3, 4.0.10 +1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade plone.app.dexterity and plone-app-dexterity to 4.1.3 or 3.2.3; plone.app.contenttypes and plone-app-contenttypes to 4.0.10 or 3.0.12.

Affected software

ProductAffectedFixed in
ploneplone.app.dexterityAffected
  • >=4.0.0 <4.1.3
  • <3.2.3
  • =5.0.0
Fixed in
  • 4.1.3
  • 3.2.3
ploneplone.app.contenttypesAffected
  • >=4.0.0 <4.0.10
  • <3.0.12
  • =5.0.0
Fixed in
  • 4.0.10
  • 3.0.12
PyPIplone-app-dexteritypkg:pypi/plone-app-dexterityOther threatsAffected
  • <3.2.3
  • >=4.0.0 <4.1.3
  • =5.0.0
Fixed in
  • 3.2.3
  • 4.1.3
PyPIplone-app-contenttypespkg:pypi/plone-app-contenttypesOther threatsAffected
  • <3.0.12
  • >=4.0.0 <4.0.10
  • =5.0.0
Fixed in
  • 3.0.12
  • 4.0.10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability has been patched. Users should upgrade to plone.app.dexterity versions 3.2.3, 4.1.3, or 5.0.1 and plone.app.contenttypes versions 3.0.12, 4.0.10, or 5.0.1 to remediate the issue. No additional mitigation steps are required once these updates are applied.

Description

plone.app.dexterity is a content-type system for the Plone content management system, and plone.app.contenttypes provides Plone’s Dexterity-based content types. Plone.app.dexterity versions through 3.2.2, 4.0.0 through 4.1.2, and 5.0.0, and plone.app.contenttypes versions through 3.0.11, 4.0.0 through 4.0.9, and 5.0.0 are vulnerable to denial of service because an authenticated user can create content with excessively long titles, descriptions, or uploaded-file names, causing Plone to become unresponsive and potentially making the resulting content difficult to edit or delete. The vulnerability is patched in plone.app.dexterity versions 3.2.3, 4.1.3, and 5.0.1, and in plone.app.contenttypes versions 3.0.12, 4.0.10, and 5.0.1.

References

Community reviews

Loading reviews…