CVE-2026-57590: Apache DolphinScheduler · Incorrect Authorization
Affects Apache DolphinSchedulerSource CVE Database V5
Not known to be exploited · CVSS 8.1 High : upgrade to 3.4.3 soon.
Data as of 5 Nov 2026, 23:24 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.4.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 24 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade Apache to 3.4.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache DolphinScheduler | Affected
| Fixed in
|
MavenApache Software Foundation/org.apache.dolphinscheduler:dolphinscheduler-apipkg:maven/Apache Software Foundation/org.apache.dolphinscheduler:dolphinscheduler-apiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Apache DolphinScheduler to version 3.4.3 or later, where this authorization vulnerability is fixed. No other mitigation steps are indicated or required.
Description
A missing authorization vulnerability exists in the Task Group APIs of Apache DolphinScheduler. The affected APIs do not properly verify whether the authenticated user has permission to access the project associated with the target Task Group. This issue affects Apache DolphinScheduler: before 3.4.3. Users are recommended to upgrade to version 3.4.3, which fixes the issue.