CVE-2026-57853: DataGerry · Template Injection
Affects DataGerrySource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 3.3.0 soon.
Data as of 4 Nov 2026, 18:28 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 8.7 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 8.8 |
- Patch
- Available – fixed in 3.3.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade DataGerry to 3.3.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DataGerryDataGerry | Affected
| Fixed in
|
GitHubDataGerrypkg:github/DataGerryOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade DataGerry to version 3.3.0 or later, where this vulnerability is fixed. No other mitigation or workaround is indicated. Applying the official fix eliminates the risk of this server-side template injection.
Description
DataGerry versions prior to 3.3.0 contain a server-side template injection vulnerability that allows authenticated users with specific permissions to execute arbitrary operating system commands. This is achieved by injecting malicious Jinja2 payloads into a template field that is rendered without sandboxing, leading to remote code execution as the web process user, which is root in default Docker setups. The vulnerability is fixed in version 3.3.0.