Skip to main content
VulnerabilityPublished Updated

CVE-2026-57997: strapi · Weak Cryptography

Affects strapiSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.3 Medium : upgrade to 5.7.0 when convenient.

Data as of 8 Nov 2026, 14:36 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.06.3
CNA (VulnCheck)CVSS 3.14.8
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Limited control over the software or limited information exposure

CISA SSVC assessment, 2026-07-01.

Patch
Available – fixed in 5.7.0
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 8 Nov 2026.

What to do

Upgrade strapi to 5.7.0.

Affected software

ProductAffectedFixed in
strapistrapiAffected
  • <5.7.0
Fixed in
  • 5.7.0
npmstrapipkg:npm/strapiOther threatsAffected
  • <5.7.0
Fixed in
  • 5.7.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Strapi to version 5.7.0 or later, where this vulnerability is fixed. Ensure that the plugin::users-permissions.jwt.algorithm configuration is explicitly set to restrict accepted JWT algorithms. Since this is a cloud service, the vendor manages remediation for hosted instances; verify with the vendor that the service is updated accordingly.

Description

CVE-2026-57997 is a vulnerability in the Strapi users-permissions plugin where the JWT algorithm restrictions are not enforced unless explicitly configured. This allows acceptance of HS384 and HS512 tokens in addition to HS256. Attackers with knowledge of the jwtSecret can create tokens using these non-standard HMAC algorithms to bypass authentication controls. The issue affects Strapi versions prior to 5.7.0 and has been fixed in version 5.7.0.

References

Community reviews

Loading reviews…