Skip to main content
VulnerabilityPublished

CVE-2026-5845: GitHub Enterprise Server · Insecure Direct Object Reference

Affects GitHub Enterprise ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.2 High : upgrade to 3.20.1 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.20.1
CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade GitHub Enterprise Server to 3.20.1.

Affected software

ProductAffectedFixed in
GitHubEnterprise ServerAffected
  • >=3.20.0 <3.20.1
  • >=3.19.0 <3.19.5
  • >=3.18.0 <3.18.8
  • >=3.17.0 <3.17.14
  • >=3.16.0 <3.16.17
  • >=3.15.0 <3.15.21
  • >=3.14.0 <3.14.26
Fixed in
  • 3.20.1

AI-suggested

This vulnerability has been fixed in GitHub Enterprise Server versions 3.20.1, 3.19.5, 3.18.8, 3.17.14, 3.16.17, 3.15.21, and 3.14.26. Users should upgrade affected GitHub Enterprise Server instances to one of these fixed versions or later to remediate the issue. Patch status is confirmed by the vendor advisory embedded in the description. No additional mitigation steps are indicated.

Description

CVE-2026-5845 is an authorization bypass vulnerability in GitHub Enterprise Server affecting versions prior to 3.21. It allows an authenticated attacker to access private repositories outside the intended installation scope, potentially including write operations. The issue arises from an authorization fallback treating a revoked or deleted installation as a global installation context. This can be exploited by chaining token revocation timing and SSH push attribution to reuse a victim-scoped token. The vulnerability has a high severity score of 7.2 and was fixed in versions 3.20.1 and later. No known exploits in the wild have been reported.

References

Community reviews

Loading reviews…