Skip to main content
VulnerabilityPublished Updated

CVE-2026-59093: weaviate · Incorrect Privilege Assignment

Affects weaviateSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 1.38.0 soon.

Data as of 8 Nov 2026, 14:35 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 3.18.8
CNA (VulnCheck)CVSS 4.08.7
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Total control over the software or total information disclosure

CISA SSVC assessment, 2026-07-06.

Patch
Available – fixed in 1.38.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 8 Nov 2026.

What to do

Upgrade weaviate to 1.38.0.

Affected software

ProductAffectedFixed in
weaviateweaviateAffected
  • <1.38.0
Fixed in
  • 1.38.0
GitHubweaviatepkg:github/weaviateOther threatsAffected
  • <1.38.0
Fixed in
  • 1.38.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Weaviate to version 1.38.0 or later, where this vulnerability is fixed. The fix ensures that role assignment enforces permission checks consistent with role creation, preventing unauthorized privilege escalation.

Description

Weaviate versions prior to 1.38.0 contain a privilege escalation vulnerability due to improper verification of permissions during RBAC role assignments. Specifically, users with limited assign_and_revoke_users or assign_and_revoke_groups permissions can assign themselves or others high-privilege roles, including the built-in admin role, without verifying that they hold the permissions contained in those roles. This flaw allows unauthorized escalation to full administrative control of the database.

References

Community reviews

Loading reviews…