Skip to main content
VulnerabilityPublished Updated

CVE-2026-59095: lobehub · Server-Side Request Forgery (SSRF)

Affects lobehubSource CVE Database V5

0
Compare

Public exploit available · CVSS 7.7 High : upgrade to 2.2.10 as a priority.

Data as of 8 Nov 2026, 14:35 UTC

CVSS 3.1 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 3.17.7
CNA (VulnCheck)CVSS 4.08.3
CISA SSVC
Exploitation
Proof of concept is public or traded
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Limited control over the software or limited information exposure

CISA SSVC assessment, 2026-07-06.

Patch
Available – fixed in 2.2.10
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 2 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CISA SSVC: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by VulnCheck

    , 4 hours before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. CISA SSVC assessment

    proof of concept public

    , 4 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA SSVC, the Metasploit, Exploit-DB and nuclei-templates index as of 8 Nov 2026.

What to do

Upgrade lobehub to 2.2.10.

Affected software

ProductAffectedFixed in
lobehublobehubAffected
  • <2.2.10
Fixed in
  • 2.2.10
GitHublobehubpkg:github/lobehubOther threatsAffected
  • <2.2.10
Fixed in
  • 2.2.10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade LobeChat to version 2.2.10 or later, where this SSRF vulnerability is fixed by using the SSRF-safe-fetch wrapper in the affected endpoints. No other mitigation is necessary as the fix is available and official.

Description

LobeChat versions before 2.2.10-canary.18 contain a server-side request forgery (SSRF) vulnerability. Authenticated attackers can exploit this flaw by supplying crafted URLs to the skill import and topic cover update endpoints, which do not use the project's SSRF-safe fetch wrapper. This allows attackers to make internal HTTP requests to arbitrary URLs, including sensitive internal services such as cloud instance metadata endpoints, potentially disclosing internal service responses and cloud credentials.

References

Community reviews

Loading reviews…