Skip to main content
VulnerabilityPublished Updated

CVE-2026-59261: OpenClaw · Incomplete List of Disallowed Inputs

Affects OpenClawSource GCVE Database

0

Not known to be exploited · CVSS 8.4 High : upgrade to 2026.5.28 soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 4.0 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2026.5.28
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade OpenClaw to 2026.5.28.

Affected software

ProductAffectedFixed in
OpenClaw OpenClawAffected
  • <2026.5.28
Fixed in
  • 2026.5.28

AI-suggested

A fixed version is indicated as 2026.5.28, which addresses this vulnerability. Users should upgrade to version 2026.5.28 or later to remediate this issue.

Description

OpenClaw versions before 2026.5.28 have a credential exposure vulnerability due to incomplete filtering of disallowed inputs. Specifically, workspace dotenv files can override provider credentials, allowing attackers with lower-trust access to certain input paths to expose sensitive data and credentials that should be protected.

References

Community reviews

Loading reviews…