CVE-2026-59638: Legion of the Bouncy Castle BC-JAVA · Improper Validation of Certificate with Host Mismatch
Affects Legion of the Bouncy Castle BC-JAVASource CVE Database V5
Not known to be exploited · CVSS 9.3 Critical : upgrade to 1.85 as a priority.
Data as of 31 Oct 2026, 08:20 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.85, 2.73.12, 2.1.24 +2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/U:AmberExploitation evidence
Disclosed: evidence found.
CVE published 3 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade BC-JAVA and bctls to 1.85; BC-LTS-JAVA and bctls-lts8on to 2.73.12; BC-FJA to 2.1.24, 2.0.24 or 1.0.24.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Legion of the Bouncy Castle Inc.BC-JAVA | Affected
| Fixed in
|
| Legion of the Bouncy Castle Inc.BC-LTS-JAVA | Affected
| Fixed in
|
| Legion of the Bouncy Castle Inc.BC-FJA | Affected
| Fixed in
|
| Legion of the Bouncy Castle Inc.BC-FJA | Affected
| Fixed in
|
| Legion of the Bouncy Castle Inc.BC-FJA | Affected
| Fixed in
|
GitHubbctlspkg:github/bctlsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
CVE-2026-59638 is a critical vulnerability in Bouncy Castle for Java where the JSSE hostname verifier CN-fallback is enabled by default despite being documented as opt-in. This affects versions before 1.85, including LTS versions before 2.73.12 and FIPS versions before specified patch releases. The flaw involves improper validation of certificates with host mismatches, categorized under CWE-297.
References
- github.com/bcgit/bc-java/wiki/CVE-2026-59638 (opens in a new tab)
- github.com/bcgit/bc-java/commit/799bd15320a6310a447863638aa3df64acef829b (opens in a new tab)
- github.com/bcgit/bc-java/commit/5ac55351cd1a8a7184d41c96a7ee87df0770240a (opens in a new tab)
- github.com/bcgit/bc-java/wiki/CVE%E2%80%902026%E2%80%9059638 (opens in a new tab)