CVE-2026-59640: Legion of the Bouncy Castle BC-JAVA · Observable Discrepancy
Affects Legion of the Bouncy Castle BC-JAVASource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 1.85 soon.
Data as of 31 Oct 2026, 20:20 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.85, 2.73.12, 2.1.13 +2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/U:AmberExploitation evidence
Disclosed: evidence found.
CVE published 3 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade BC-JAVA and bcpg to 1.85; BC-LTS-JAVA and bcpg-lts8on to 2.73.12; BC-FJA to 2.1.13, 2.0.13 or 1.0.13.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Legion of the Bouncy Castle Inc.BC-JAVA | Affected
| Fixed in
|
| Legion of the Bouncy Castle Inc.BC-LTS-JAVA | Affected
| Fixed in
|
| Legion of the Bouncy Castle Inc.BC-FJA | Affected
| Fixed in
|
| Legion of the Bouncy Castle Inc.BC-FJA | Affected
| Fixed in
|
| Legion of the Bouncy Castle Inc.BC-FJA | Affected
| Fixed in
|
GitHubbcpgpkg:github/bcpgOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
No temporary or official fixes have been documented at this time.
Description
CVE-2026-59640 is a high-severity vulnerability in Bouncy Castle for Java (BC-JAVA) involving an OpenPGP CFB quick-check oracle on symmetric/session-key paths. This affects versions before 1.85, versions from 2.73.0 up to but not including 2.73.12, and certain FIPS series versions. The vulnerability is categorized under CWE-203 (Observable Discrepancy).