CVE-2026-59650: Legion of the Bouncy Castle BC-JAVA · Improper Input Validation
Affects Legion of the Bouncy Castle BC-JAVASource CVE Database V5
Not known to be exploited · CVSS 9.3 Critical : upgrade to 1.85 as a priority.
Data as of 31 Oct 2026, 08:20 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.85, 2.73.12
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/U:AmberExploitation evidence
Disclosed: evidence found.
CVE published 3 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade BC-JAVA and bcprov to 1.85; BC-LTS-JAVA and bcprov-lts8on to 2.73.12.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Legion of the Bouncy Castle Inc.BC-JAVA | Affected
| Fixed in
|
| Legion of the Bouncy Castle Inc.BC-LTS-JAVA | Affected
| Fixed in
|
GitHubbcprovpkg:github/bcprovOther threats | Affected
| Fixed in
|
GitHubbcprov-lts8onpkg:github/bcprov-lts8onOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, users should consider avoiding the use of affected versions (<1.85 and >=2.73.0 <2.73.12) for critical cryptographic operations or apply any recommended temporary mitigations from the vendor.
Description
CVE-2026-59650 is a critical vulnerability in Legion of the Bouncy Castle Inc.'s BC-JAVA library affecting versions before 1.85 and LTS versions from 2.73.0 up to but not including 2.73.12. The flaw involves improper input validation in the MTI/A0 Diffie-Hellman agreement process, where an unvalidated peer value is exponentiated. This can lead to severe cryptographic failures. The vulnerability has a high CVSS 4.0 score of 9.3, indicating network exploitable with no privileges or user interaction required. There are no known exploits in the wild at this time.