Skip to main content
VulnerabilityPublished

CVE-2026-59823: BerriAI litellm · Server-Side Request Forgery (SSRF)

Affects BerriAI litellmSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.83.9 when convenient.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.83.9
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade litellm and berriai/litellm to 1.83.9.

Affected software

ProductAffectedFixed in
BerriAIlitellmAffected
  • <1.83.9
Fixed in
  • 1.83.9
GitHubberriai/litellmpkg:github/berriai/litellmOther threatsAffected
  • <1.83.9
Fixed in
  • 1.83.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade LiteLLM to version 1.83.9 or later, where this SSRF vulnerability is fixed. No other mitigation is required as the fix addresses the root cause by properly validating the user_config parameter.

Description

CVE-2026-59823 is a Server-Side Request Forgery (SSRF) vulnerability in BerriAI's LiteLLM proxy server versions prior to 1.83.9. An authenticated user with a valid virtual key could exploit this flaw by placing an api_base parameter inside the user_config request body, bypassing existing safety checks. This allows the attacker to redirect server-side requests to internal or external hosts not normally accessible, potentially exposing sensitive endpoints. The issue is resolved in version 1.83.9.

References

Community reviews

Loading reviews…