CVE-2026-59965: jhb-software payload-plugins · Incorrect Authorization
Affects jhb-software payload-pluginsSource CVE Database V5
Not known to be exploited · CVSS 7.1 High : upgrade to 0.8.0 soon.
Data as of 30 Oct 2026, 20:25 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.8.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 15 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade payload-plugins and payload-alt-text-plugin and jhb-software/payload-plugins to 0.8.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| jhb-softwarepayload-plugins | Affected
| Fixed in
|
| @jhb.softwarepayload-alt-text-plugin | Affected
| Fixed in
|
GitHubjhb-software/payload-pluginspkg:github/jhb-software/payload-pluginsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to version 0.8.0 or later where this vulnerability is fixed. Prior to upgrading, restrict access to the affected API endpoints to trusted users only if possible. No other vendor advisory mitigation instructions are provided.
Description
Payload Plugins is a collection of plugins designed to enhance Payload CMS. In 0.7.0, @jhb.software/payload-alt-text-plugin exposes POST /api/alt-text-plugin/generate and POST /api/alt-text-plugin/bulk with a default guard that accepts any authenticated user, while alt-text/src/endpoints/generateAltText.ts and alt-text/src/endpoints/bulkGenerateAltTexts.ts call req.payload.findByID and req.payload.update without overrideAccess: false. Payload therefore defaults overrideAccess to true and skips the target collection's read and update access functions. An authenticated low-privilege user can supply id, collection, locale, and update values to read arbitrary protected upload documents and overwrite their alt and keywords fields, even when the collection permits those operations only to administrators. A control Local API call with overrideAccess: false is denied, confirming that the plugin endpoint bypasses otherwise effective collection rules. This vulnerability is fixed in 0.8.0.
References
- github.com/jhb-software/payload-plugins/security/advisories/GHSA-4qpv-39hg-f7fx (opens in a new tab)
- github.com/jhb-software/payload-plugins/pull/159 (opens in a new tab)
- github.com/jhb-software/payload-plugins/commit/e39634868ce13a414e2981e219befc58101654d3 (opens in a new tab)
- github.com/jhb-software/payload-plugins/releases/tag/alt-text@0.8.0 (opens in a new tab)