CVE-2026-6011: OpenClaw · Server-Side Request Forgery
Affects OpenClawSource CVE Database V5
Public exploit available · CVSS 6.3 Medium.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 10 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| OpenClaw | Affected
| Fixed in– |
GitHubopenclaw/openclawpkg:github/openclaw/openclawOther threats | Affected
| Fixed in– |
CPE configurations (1)
cpe:2.3:a:openclaw:openclaw:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available by upgrading OpenClaw to version 2026.1.29, which includes the patch identified by commit b623557a2ec7e271bda003eb3ac33fbb2e218505. It is strongly recommended to apply this upgrade to remediate the vulnerability. No other vendor advisory or temporary mitigations are provided. Patch status is confirmed by the vendor's versioning information.
Description
A weakness has been identified in OpenClaw up to 2026.1.26. Affected by this issue is some unknown functionality of the file src/agents/tools/web-fetch.ts of the component assertPublicHostname Handler. Executing a manipulation can lead to server-side request forgery. The attack can be executed remotely. This attack is characterized by high complexity. The exploitation is known to be difficult. The exploit has been made available to the public and could be used for attacks. Upgrading to version 2026.1.29 can resolve this issue. This patch is called b623557a2ec7e271bda003eb3ac33fbb2e218505. Upgrading the affected component is advised.
References
- vuldb.com/vuln/356567 (opens in a new tab)
- vuldb.com/vuln/356567/cti (opens in a new tab)
- vuldb.com/submit/795224 (opens in a new tab)
- github.com/zast-ai/vulnerability-reports/blob/main/openclaw/ssrf.md (opens in a new tab)
- github.com/openclaw/openclaw/commit/b623557a2ec7e271bda003eb3ac33fbb2e218505 (opens in a new tab)
- github.com/openclaw/openclaw/releases/tag/v2026.1.29 (opens in a new tab)
- github.com/openclaw/openclaw/ (opens in a new tab)