Skip to main content
VulnerabilityPublished Updated

CVE-2026-6106: 1Panel-dev MaxKB · Cross-site Scripting

Affects 1Panel-dev MaxKBSource CVE Database V5

0
Compare

Public exploit available · CVSS 5.1 Medium · fixed in 2.8.0 : patch 1Panel-dev MaxKB as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.8.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
1Panel-devMaxKBAffected
  • =2.2.0
  • =2.2.1
Fixed in–
GitHub1panel-dev/MaxKBpkg:github/1panel-dev/MaxKBOther threatsAffected
  • =2.2.0
  • =2.2.1
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:maxkb:maxkb:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade the affected 1Panel-dev MaxKB product to version 2.8.0 or later, which contains the official fix for this vulnerability. The vendor has released this patch promptly after being notified. No additional mitigation steps are indicated or required beyond applying the update.

Description

A vulnerability was detected in 1Panel-dev MaxKB up to 2.2.1. This vulnerability affects the function StaticHeadersMiddleware of the file apps/common/middleware/static_headers_middleware.py of the component Public Chat Interface. The manipulation of the argument Name results in cross site scripting. The attack may be launched remotely. The exploit is now public and may be used. Upgrading to version 2.8.0 is able to resolve this issue. The patch is identified as 026a2d623e2aa5efa67c4834651e79d5d7cab1da. It is recommended to upgrade the affected component. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

References

Community reviews

Loading reviews…