Skip to main content
VulnerabilityPublished Updated

CVE-2026-6107: 1Panel-dev MaxKB · Cross-site Scripting

Affects 1Panel-dev MaxKBSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.1 Medium · fixed in 2.8.0 : update 1Panel-dev MaxKB when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.8.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:X

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
1Panel-devMaxKBAffected
  • =2.6.0
  • =2.6.1
Fixed in–
GitHub1panel-dev/MaxKBpkg:github/1panel-dev/MaxKBOther threatsAffected
  • =2.6.0
  • =2.6.1
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:maxkb:maxkb:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrading to version 2.8.0 of 1Panel-dev MaxKB fully addresses this vulnerability. The vendor has released an official fix, and applying this update is the recommended remediation. No additional mitigation steps are indicated by the vendor advisory.

Description

A flaw has been found in 1Panel-dev MaxKB up to 2.6.1. This issue affects some unknown processing of the file apps/common/middleware/chat_headers_middleware.py of the component ChatHeadersMiddleware. This manipulation of the argument Name causes cross site scripting. Remote exploitation of the attack is possible. Upgrading to version 2.8.0 is capable of addressing this issue. Patch name: 026a2d623e2aa5efa67c4834651e79d5d7cab1da. Upgrading the affected component is advised. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

References

Community reviews

Loading reviews…