CVE-2026-61466: Apache CXF · Missing Critical Step in Authentication
Affects Apache CXFSource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical · fixed in 4.2.3 : patch Apache CXF as a priority.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.2.3, 4.1.8, 3.6.12
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 6 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade Apache to 4.2.3, 4.1.8 or 3.6.12.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache CXF | Affected
| Fixed in
|
| Apache Software FoundationApache CXF | Affected
| Fixed in
|
| Apache Software FoundationApache CXF | Affected
| Fixed in
|
MavenApache Software Foundation/org.apache.cxf:cxf-rt-rs-security-oauth2pkg:maven/Apache Software Foundation/org.apache.cxf:cxf-rt-rs-security-oauth2Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade affected Apache CXF versions to 3.6.12, 4.1.8, or 4.2.3, which include fixes for this vulnerability. No other mitigation steps are indicated. Patch status is confirmed by the vendor advisory recommending these versions.
Description
Apache CXF's OAuth2 Dynamic Client Registration endpoint improperly accepts and stores the 'scope' parameter from client registration requests without validating it against an allowlist. This allows clients to self-assign privileged scopes during registration. The issue affects multiple versions prior to 3.6.12, 4.1.8, and 4.2.3. Users are advised to upgrade to these fixed versions to mitigate the vulnerability.