Skip to main content
VulnerabilityPublished Updated

CVE-2026-61483: Apache Lucy · Uncontrolled Recursion

Affects Apache LucySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 0.8.0 soon.

Data as of 3 Nov 2026, 22:58 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.0% chance of exploitation in 30 days – higher than 63% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.8.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade Apache Lucy to 0.8.0.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache LucyAffected
  • <0.8.0
Fixed in
  • 0.8.0
Mavenorg.apache.lucene/lucypkg:maven/org.apache.lucene/lucyOther threatsAffected
  • *
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should consider migrating to an alternative supported product. If migration is not immediately possible, restrict access to Apache Lucy instances to trusted users only to reduce exposure.

Description

** UNSUPPORTED WHEN ASSIGNED ** Uncontrolled Recursion vulnerability in Apache Lucy. This issue affects Apache Lucy: all versions. As this project is retired, we do not plan to release a version that fixes this issue. Users are recommended to find an alternative or restrict access to the instance to trusted users. NOTE: This vulnerability only affects products that are no longer supported by the ASF. Lucy is now maintained outside of the ASF at https://github.com/lucysearch

References

Community reviews

Loading reviews…