Skip to main content
VulnerabilityPublished Updated

CVE-2026-61544: rust-libp2p · Uncaught Exception

Affects rust-libp2pSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.2 High : upgrade to 0.13.1 soon.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.13.1
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade rust-libp2p and libp2p/rust-libp2p to 0.13.1.

Affected software

ProductAffectedFixed in
libp2prust-libp2pAffected
  • <0.13.1
Fixed in
  • 0.13.1
crates.iolibp2p/rust-libp2ppkg:cargo/libp2p/rust-libp2pOther threatsAffected
  • <0.13.1
Fixed in
  • 0.13.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade libp2p-quic to version 0.13.1 or later, where this vulnerability is fixed. No other mitigation is indicated. Patch status is confirmed fixed in version 0.13.1.

Description

CVE-2026-61544 is a high-severity vulnerability in the rust-libp2p implementation of the libp2p networking stack. Versions prior to 0.13.1 of libp2p-quic can panic during an inbound QUIC handshake if a remote peer presents a valid short-lived TLS certificate that expires before the final TLS 1.3 handshake fragment is received. This causes an uncaught exception due to a repeated certificate validity check, leading to application termination for affected listeners. The issue is fixed in version 0.13.1.

References

Community reviews

Loading reviews…